к списку производителей

Weintek

Документация
Программное обеспечение
Советы
Часто задаваемые вопросы
HMI Weintek
Презентация по HMI Weintek
RU
Краткий каталог HMI Weintek
RU
Сенсорные панели Weintek. Таблица сравнения программных возможностей
EN
Сенсорные панели Weintek. Руководство по подключению контроллеров
EN
Серия cMT X
Сравнение программных возможностей панелей серии cMT X
RU
Преимущества перехода к панелям серии cMT X
RU
Панели серии cMT X
RU
Серия cMT
cMT-FHDX-820. Инструкция по установке
EN
cMT-SVR-200. Инструкция по установке
EN
cMT-G02. Инструкция по установке
EN
cMT-G01. Руководство пользователя
EN
cMT-G01. Инструкция по установке
EN
cMT-SVR. Руководство пользователя
EN
cMT-SVR. Инструкция по установке
EN
Cloud HMI. Брошюра
EN
Сравнительная таблица функциональных возможностей панелей семейств iP / iE / XE / eMT / сMT
EN
MT8000
Сравнительная таблица функциональных возможностей панелей семейств iP / iE / XE / eMT / сMT
EN
Сенсорные панели MT8121XE/MT8150XE. Инструкция по установке
EN
MT8000iE, XE, mTV, iP серии. Брошюра
EN
ПО
Программный пакет EasyLauncher. Руководство пользователя
EN
Программный пакет EasyBuilder Pro. Руководство пользователя
EN
Программный пакет EasyAccess 2.0. Руководство пользователя
EN
Спецификации
Спецификация MT8071iER
EN
Спецификация cMT-SVR-102
EN
Спецификация cMT-FHDX-820
EN
Спецификация cMT-SVR-200
EN
Спецификация cMT-SVRX-822
EN
Спецификация cMT-G01
RU EN
Спецификация cMT-G02
EN
Спецификация MT8090XE
EN
Спецификация MT8071IE
EN
Спецификация MT8102IE
EN
Спецификация MT8121XE3
EN
Спецификация MT8051iE
EN
Спецификация M02
EN
Спецификация cMT+CODESYS
EN
Спецификация EasyAccess 2.0
EN
Спецификация cMT3108XH
EN
Спецификация cMT3072XH
EN
Спецификация cMT2166X
EN
Спецификация cMT3162X
EN
Спецификация cMT2078X
EN
Спецификация cMT2158X
EN
Спецификация cMT3072X2
EN
Спецификация cMT3092X
EN
Спецификация cMT3152X
EN
Спецификация cMT2108X2
EN
Спецификация cMT3072XHT
EN
Спецификация cMT1106X
EN
Спецификация MT8072IP
RU EN
Спецификация cMT2128X
RU EN
Программное обеспечение удаленного доступа EasyLauncher для панелей серии Cloud HMI cMT-iPC
EN
Программа просмотра проектов cMT Viewer для панелей и сервера серии Cloud HMI
EN
Обучающие видео по работе с ПО EasyBuilder Pro
EN
EasyBuilder Pro версии 6
EN
EasyAccess 2.0
EN
EasyBuilderPro. Действия по триггеру
RU
Подключение панелей Weintek к ПЛК Siemens S7-300/ET200S (Ethernet)
RU
Подключение панелей Weintek с EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0
RU
Подключение панелей Weintek с EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0
RU
Синхронизация часов панелей Weintek с часами ПК
RU
Важные замечания при использовании USB Host и USB Client на панелях Weintek
RU
Список ресурсов для скачивания программных продуктов CODESYS для iR серии
EN
Работа панелей Weintek серий MT8000iE и MT8000iP с драйвером Siemens S7-1200/1500 в версиях EasyBuilder Pro: 6.03.01 или более поздних
RU
CODESYS для панелей Weintek серии cMT
RU
Панели оператора Weintek

Совместимы ли версии V5.01.01 и V5.01.02 ПО EasyBuilder Pro?

Ответ:

EasyBuilder Pro V5.01.01 больше недоступен для скачивания по следующей причине: Объект Data Block Display EasyBuilder Pro V5.01.01 хранит данные новым способом. Поэтому при попытке редактирования проекта, созданного в версии V5.00.01 или более ранней, проект не открывается, если он содержит Data Block Display.

В EasyBuilder Pro V5.01.02 использован способ хранения данных в Data Block Display, который совместим с V5.00.01 и более ранними версиями EasyBuilder Pro, но не совместим с V5.01.01. Если вы уже редактировали файл проекта, используя V5.01.01, то файл проекта не может быть открыт в EasyBuilder Pro V5.01.02 (если в проекте использован объект Data Block Display). В этом случае необходимо декомпилировать проект или же удалить объект Data Block Display в файле проекта V5.01.01, а затем открыть проект в EasyBuilder Pro V5.01.02.

EasyBuilder Pro V5.01.02 включает в себя все новые возможности и исправления V5.01.01.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0

Ответ:

Недавно Siemens сделал большие изменения в версии Firmware ПЛК S7-1200, поэтому драйвер S7-1200 больше не может установить связь между EasyBuilder8000 и ПЛК S7-1200 с Firmware V4.0. Чтобы установить связь между панелями Weintek I серии и ПЛК S7-1200 с Firmware v4.0, пожалуйста, используйте драйвер S7-1500.

Пожалуйста, выполните следующии шаги для настройки среды связи, иначе, могут возникнуть ошибки.

Шаг 1. Выберите опцию [General] » [Protection] » [Permit access with PUT/GET communication from remote partner].

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 1

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 2

Шаг 2. Пожалуйста не выбирайте [DB UTILITAIRES] » [Attributes] » [Optimized block access]. Важно, что бы данная опция во всех блоках данных не была выбрана.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 3

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 4

Далее объясняется, как импортировать адресные теги, используя TIA.

Шаг 1. Экспорт тегов ПЛК (формат файлов .xlsx). В разделе [PLC tags] создать адресные теги, а затем щелкните значок экспорта.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 5

Назначьте директорию для сохранения файла и нажмите кнопку ОК.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 6

Шаг 2. Экспорт блоков данных (формат файлов .SCL). В разделе [Data блоков] создайте "Data_block_1 [DB1]". Щелкните правой кнопкой мыши на [DB1], а затем нажмите [Generate source from blocks]для создания .SCL файла.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 7

Шаг 3. В EasyBuilder8000, выберите [New PLC...], тип устройства "Siemens S7-1500 (Ethernet)", а затем нажмите кнопку [Settings ...], чтобы задать параметры.

Шаг 4. Нажмите [Import Tag…].

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 8

Шаг 5. Выберите теги ПЛК и блоки данных, которые необходимо импортировать. Пожалуйста, проверьте, правильность номеров DB.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 9

Шаг 6. Нажмите [Import]. После успешного импорта будет отображено соответствующее сообщение. Нажмите кнопку OK, чтобы сохранить изменения.

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 10

Поддерживаемые типы данных:

Как подключить панель Weintek EasyBuilder8000 к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 11

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0

Ответ:

При подключении панелей Weintek с программным обеспечением EasyBuilderPRO к ПЛК S7-1200 с прошивкой V4.0 существует ряд ограничений, поэтому, чтобы избежать ошибок связи, выполните следующие действия для настройки.

Щелкните правой кнопкой мыши на программе ПЛК, а затем нажмите кнопку [Properties].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 1

Выберите [Protection], а затем выберите [Permit access with PUT/GET communication from remote partner (PLC,HMI,OPC,…].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 2

Следующая часть знакомит как экспортировать теги из ПЛК S7-1200 и программных блоков. 

Экспорт ПЛК тегов (I,Q,M tags)

1. В разделе [PLC tags] выберите [Show all tags].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 3

2. Нажмите [Export] для экспорта тегов.

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 4

3. Выберите директорию, куда сохранять экспортируемый файл и нажмите [OK].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 5

Экспортирование программных блоков (DB)

1. Если база данных содержит данные типа Struct, обратите внимание на следующие ограничения.

Пожалуйста, по крайней мере, добавьте один элемент данных в БД, который не принадлежит к данным типа Struct, в противном случае, данные не могут быть импортированы в EasyBuilder.

Многомерные массивы и Многослойные Struct не поддерживаются.

После построения БД, пожалуйста, проделайте следующие действия для адрессов Struct:

(1) Полностью скопировать данные типа Struct.

(2) Удалите данные.

(3) Добавить новую строку.

(4) Вставьте данные.

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 6

2. Нажмите правой кнопкой на DB, выберите [Generate source from blocks], и введите имя файла для сохранения

После построения и импортирования тегов и программных блоков (DB) ПЛК, нажмите [Download to device].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 7

Импортирование тегов и программных блоков(DB) ПЛК

1. Запустите EasyBuilder и установите IP адрес.

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 8

2. Нажмите [Import Tag…].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 9

3. Выберите переменные и программные блоки ПЛК, которые будут импортированы. Пожалуйста, не забудьте изменить номер DB и выберите [Use S7-1200 firmware version 4.0 or later versions]. Нажмите [Import] для импорта файлов. Адреса I, Q, и M будут проверены, в случае возникновения ошибки, связь не будет установлена. Если это произойдет, проверьте параметры связи, и повторите попытку.

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 10

4. В поле "Состояние импорта (Import Status)" будет показан результат, нажмите [OK].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 11

5. Выберите теги которые должны быть импортированы и нажмите [OK].

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 12

6. Следующее сообщение отображается, когда импорт успешно завершен.

Как подключить панель Weintek EasyBuilderPRO к ПЛК Siemens S7-1200 с Firmware4.0 - рисунок 13

Какой формат данных рецептов (Recipe Data Format)?

Ответ:

Пример: Настроить значения RW0~RW4, как 16-ти битовые беззнаковые (16-bit unsigned), а RW5~RW13 to 32-ти битовые беззнаковые (32-bit unsigned)

Шаг 1. Настройте формат данных рецептов в редакторе «Recipe Editor»

Какой формат данных рецептов (Recipe Data Format) - рисунок 1

Шаг 2. Данные показанные ниже: Data 0~Data 4 являются содержанием адресов RW0~RW4.
Data5~Data9 являются содержанием адресов RW5~RW13.
Какой формат данных рецептов (Recipe Data Format) - рисунок 2

Шаг 3. Форматы данных в шестнадцатеричном коде (HEX) приведены в списке; младшие байты первые (low bytes first).
RW0 = 01 00
RW1 = 02 00
RW2 = 03 00
RW3 = 04 00
RW4 = 05 00
RW5 = 0B 00 00 00
RW7 = 0C 00 00 00
RW9 = 0D 00 00 00
RW11 = 0E 00 00 00
RW13 = 0F 00 00 00
Какой формат данных рецептов (Recipe Data Format) - рисунок 2

Передача файла рецептов [Transmitting Recipe File]

Шаг 1. Введите адрес ftp и пароль, в этом примере HMI с IP адресом 192.168.1.103 и паролем 111111. (ftp://uploadhis:111111@192.168.1.103)

Какой формат данных рецептов (Recipe Data Format) - рисунок 3

Шаг 2. Щелкните по «Enter», будет показана история записей HMI, включая папку «recipe».

Какой формат данных рецептов (Recipe Data Format) - рисунок 4

Шаг 3. Скопируйте вновь сгенерированный файл «recipe.rcp» в папку «recipe», чтобы закончить обновление.

Критерии сохранения данных в памяти панели и внешнем устройстве

Ответ:

Данные в режиме реального времени могут быть потеряны при выключении панели. (Режим реального времени «Real time» означает, что не указано место хранения файлов архива «history files»).

Критерии сохранения данных в памяти панели и внешнем устройстве - шаг 1

Если пользователь выбрал для сохранения «Data log» и «Event log» вариант «Save to HMI memory», данные могут быть сохранены если размер данных больше 4kb, иначе, пользовать должен использовать системную переменную [LB-9034: save event/data log to HMI, USB disk, CF card (set ON)] чтобы принудительно сохранить данные.

Есть способ переключать LB-9034 автоматически. Пользователь может установить «Notification»- Извещение в архиве «event log» о возникновении события (event); Бит LB-9034 будет переходить в состояние «ON», чтобы сохранять файл архива в памяти панели автоматически, настройки следующие:

Критерии сохранения данных в памяти панели и внешнем устройстве - шаг 2

Совет: Пользователь может использовать «LW_bit 901800», чтобы переключать LB-9034 каждые две минуты, как показано на рисунке внизу
Критерии сохранения данных в памяти панели и внешнем устройстве - шаг 2
Критерии сохранения данных в памяти панели и внешнем устройстве - шаг 3

Если пользователь сохраняет архивные файлы «Data log» и «Event log» на внешнем устройстве, например, на USB диске или SD карте, данные могут быть сохранены немедленно.

Данные «EM» сохраняются только на внешних устройствах, поэтому данные «EM» могут быть сохранены немедленно.

Для того чтобы продлить жизнь Флэш-памяти панели, система будет проверять адреса данных рецептов каждую минуту, если данные «Recipe Data» изменились, система будет автоматически сохранять файл во Флэш-памяти, чтобы избежать потери данных при выключении панели.

EasyBuilder Pro предоставляет пользователю системный бит [LB-9029: save all recipe data to machine (set ON)] – сохранять все данные рецептов в машине, когда бит=ON , чтобы сохранять «Recipe Data» вручную. EasyBuilder Pro будет сохранять «Recipe Data», когда пользователь установит бит [LB-9029] в состояние «ON».

Как транслировать файл с расширением «.dtl» в файл с расширением «.csv»

Ответ:

1. Когда пользователь хочет получить файл «*.dtl» от HMI, надо открыть «Project Manager» и нажать «EasyConverter».

Как транслировать файл с расширением «.dtl» в файл с расширением «.csv» - шаг 1

2. Выберите «Open file» и ,затем, желаемый файл « *.dtl» на Вашем ПК.

Как транслировать файл с расширением «.dtl» в файл с расширением «.csv» - шаг 2

3. Нажмите «OK», чтобы прочитать файл «*.dtl».

Как транслировать файл с расширением «.dtl» в файл с расширением «.csv» - шаг 3

4. Нажмите пиктограмму “EXCEL”, чтобы транслировать файл.

Как транслировать файл с расширением «.dtl» в файл с расширением «.csv» - шаг 4

5. Файл «*.dtl» будет транслирован Excel в файл «*.csv».

Как транслировать файл с расширением «.dtl» в файл с расширением «.csv» - шаг 5

Как транслировать файл excel в файл с расширением «.emi»

Ответ:

1. Откройте “Recipe/Extended Memory Editor”

Как транслировать файл excel в файл с расширением «.emi» - шаг 1

2. Откройте файл «.emi», введите данные, затем нажмите «OK».

Как транслировать файл excel в файл с расширением «.emi» - шаг 2

3. Сохраните файл, как «*.csv».

Как транслировать файл excel в файл с расширением «.emi» - шаг 3

4. Отредактируйте «em0_1.csv» в Excel

Как транслировать файл excel в файл с расширением «.emi» - шаг 4

5. После редактирования (em0_1.csv), откройте «csv» в редакторе рецептов (Recipe Editor) и Вы увидите, что данные изменились

Как транслировать файл excel в файл с расширением «.emi» - шаг 5

6. Используйте “Save as”, чтобы сохранить файл с именем «em0_1.emi».

Как транслировать файл excel в файл с расширением «.emi» - шаг 6

Как увеличить скорость отображения в MT8000?

Ответ:

При отображении больших изображений с использованием 65536 цветов в качестве фона (background image) может происходить замедление скорости процессов панели. Пользователь может последовать следующим рекомендациям, чтобы увеличить скорость отображения

Как увеличить скорость отображения в MT8000 - шаг 1

Шаг 1

При использовании файла изображения в качестве фона, размер его не должен превышать размера экрана. Рекомендуем использовать формат «.BMP». На рисунке показан дисплей с разрешением 640х480, размер импортируемого изображения будет ограничен 640х480. (Размер можно увидеть в окне предпросмотра “Get Picture”).

Как увеличить скорость отображения в MT8000 - шаг 2

Если размер изображения превышает размер экрана панели, Вы можете экспортировать изображение и изменить размер инструментами WINDOWS.

Как увеличить скорость отображения в MT8000 - шаг 3

Шаг 2

Объект с рисунком - «Picture Object» использует изображение с оригинальными измерениями. Отметьте “Set to original dimensions” в диалоге “New Picture Object”.

Как увеличить скорость отображения в MT8000 - шаг 4

Иногда, размер изображения уже превышает размер экрана. Даже при выбранном варианте “Set to original dimensions”, это изображение не может быть показано в оригинальном размере. Вы должны перейти к Шагу 1, изменить размер изображения и импортировать его вновь.

Сообщение об ошибке (0xc0000005)

Ответ:

При работе EasyBuilder Pro.exe, если появилось сообщение об ошибке (как показано на рисунке внизу), проверьте не установлена ли программа «AVAST ANTIVIRUS» на Вашем компьютере.

Сообщение об ошибке (0xc0000005) - рисунок 1

AVAST ANTIVIRUS version 5.1.889 или новее имеет свойство конфликтовать с EasyBuilder Pro и вызывать ошибки в выполнении программы EasyBuilder Pro. Чтобы исправить положение, переведите AVAST ANTIVIRUS в «Паузу» или удалите антивирус из компьютера

Сообщение об ошибке (0xc0000005) - рисунок 2

Используйте EasyBuilder Pro V4.43, для возможности одновременной работы AVAST и EasyBuilder Pro.

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель?

Ответ:

MT8000 имеет возможность создавать сквозное соединение Ethernet (pass-through), которое позволяет компьютеру связаться с ПЛК через панель. В этой ситуации роль панели аналогична роли конвертера.

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 1

Сначала на компьютере должен быть создан виртуальный последовательный порт. Прикладная программа на компьютере сможет связываться с ПЛК по этому виртуальному последовательному порту.
Порядок действий следующий:
1. Откройте «Project Manager» и нажмите кнопку [ Pass-through ];

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 2

2. Пометьте селекторную кнопку [ Ethernet ], и нажмите кнопку [ Install ], чтобы установить драйвер виртуального последовательного порта ;

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 3

3. Установите драйвер ...

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 4

4. Нажмите [ Continue Anyway ] – Продолжать в любом случае.

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 5

5. Установка драйвера виртуального последовательного порта завершена. Номер нового виртуального COM – порта найден

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 6

6. Check out the [ Computer Management ] to see if the virtual COM port is successfully installed

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 7

7. Выберите [ Virtual Serial Port ] и щелкните правой кнопкой мышки . Выберите [ Properties ], чтобы изменить номер COM порта;

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 8

8. Сделаем, для примера, соединение ПЛК Fatek и MT8000.

Если IP адрес панели MT8000: 192.168.1.200 и настройки ПЛК следующие:

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 9

9. В окне[ Pass-through ] window, установим IP адрес панели «HMI IP» : 192.168.1.200 ; Назначим номер COM порта: COM1, который будет портом соединяющим MT8000 и PLC ; Тип этого COM порта: RS232.
Эти настройки соответствуют настройкам введенным ранее; Нажмите кнопку [ Apply ]

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 10

10. Откроем пакет программирования ПЛК Fatek PLC: «WinProladder» ;
В меню «PLC» выберем пункт [ On-Line];

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 11

11. Выберем COM порт

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 12

12. Установим номер COM порта: COM3, который будет «Virtual Serial Port» с номером, который мы установили на шаге 5 ;

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 13

13. Соединение состоялось

рис.

14. Пример соединения Компьютер-Панель-ПЛК;

Как создать сквозное соединение ПЛК – компьютер по Ethernet через панель - шаг 14

Как транслировать проект MT500 в проект MT8000?

Ответ:

1. Запустите EasyBuilder Pro, выберите “Tool / Translate MT500 Project”

Как транслировать проект MT500 в проект MT8000 - шаг 1

2. Найдите в “MT500 EOB file” и выберите файл с расширением «*.eob», нажмите “Translate”.

Как транслировать проект MT500 в проект MT8000 - шаг 2

3. При появлении сообщения “succeeded”- успешное завершение, нажмите “Exit”.

Как транслировать проект MT500 в проект MT8000 - шаг 3

4. В диалоге «open file», выберите файл с расширением «*.mtp» и нажмите “Open”.

Как транслировать проект MT500 в проект MT8000 - шаг 4

5. Выбранный файл проекта теперь проект MT8000 и может редактироваться пользователем.

Как транслировать проект MT500 в проект MT8000 - шаг 5

Примечание: До трансляции, проверьте, поддерживает ли EasyBuilder Pro соответствующий тип ПЛК (“Edit / System Parameters / Device / New / PLC type“)

Как сохранить изображения экрана симулятора проекта?

Ответ:

Копирование и сохранение изображения (Screen capture) всегда необходимо пользователю при написании руководств. Существует два способа сохранения изображения экранов проекта запущенного в режиме «симуляции»:

A. Сохранить экран средствами компьютера;
B. Использовать функцию “Screen hard copy” EasyBuilder Pro:

----------------------------------------

A. Сохранение экрана средствами компьютера:

В режиме «on-line simulation» или «off-line simulation», нажмите клавиши “Alt+Print Screen” для сохранения изображения в буфере. Вставьте его в программу редактирования изображений и сохраните его.

Сохранение экрана средствами компьютера

------------------------------------------

B. Использование функции “Screen hard copy” EasyBuilder Pro:

1. Откройте файл проекта EasyBuilder Pro. Создайте функциональную кнопку «function key»и пометьте селекторную кнопку “Screen hard copy” в окне настроек в закладке «General». Настройте принтер на “USB disk 1”.

Примечание: Рекомендуем создавать объект «functionkey» в Общем окне - “CommonWindow”, так как объекты в этом окне могут быть применены ко всем другим окнам;

Нажмите “Object >>Button >> Function Key”:

Использование функции “Screen hard copy” EasyBuilder Pro

2.Во всплывшем окне, пометьте селекторную кнопку “Screen hard copy” в окне настроек в закладке «General». Настройте принтер на “USB disk 1”. Нажмите “OK” для завершения настройки.

Использование функции “Screen hard copy” EasyBuilder Pro - шаг 2

3. Запустите режим «off-line simulation». Нажмите кнопку «print» созданную ранее, чтобы скопировать изображение на экране симулятора и сохраните файл изображения (image file) по пути: “\usb1\hardcopy”.

Использование функции “Screen hard copy” EasyBuilder Pro - шаг 3

Изображение сохранено по следующему пути - C:\EasyBuilder Pro\usb1\hardcopy:

Использование функции “Screen hard copy” EasyBuilder Pro - шаг 4

Как сделать резервную копию проекта?

Ответ:

Проект EasyBuilder Pro содержит файл – источник проекта (*.mtp), и ряд библиотечных файлов (*.flb, *.blb, *.plb, *.slb, *.snd, *.lbl, and *.glb). Эти файлы можно индивидуально копировать в другое место для архивирования, или можно выбрать функцию «Compress/Uncompress» - сжатие/разворачивание из меню «Tools» EasyBuilder Pro.

Шаг 1.

Выберите «Compress/Uncompress» из меню«Tools».

Как сделать резервную копию проекта - шаг 1

Шаг 2.

Будет открыт следующий диалог. Нажмите “Browse”, чтобы выбрать проект для архивирования.

Как сделать резервную копию проекта - шаг 2

Все файлы, ассоциированные с проектом, будут сжаты и сохранены в файле с расширением «*.cmp». Сжатый файлы «CMP» можно архивировать, после успешного выполнения данного шага.

Как очистить файл архива событий?

Ответ:

В памяти панелей MT8000/6000 можно хранить данные о событиях (event log data). Существует три способа очистки файлов архивных данных в памяти панели.

1. Project manager >>Download -> сделать пометку [Reset event log] и нажать «Download».

Как очистить файл архива событий - шаг 1

или нажать кнопку «Download» >> write in HMI IP >> отметить [Reset event log] и [reboot HMI after download] >> нажать кнопку «Download».

Как очистить файл архива событий - шаг 2

2. Используйте LB-9022, чтобы удалить самый старый файл архива событий (установить в ON)
Используйте LB-9023, чтобы удалить все файлы архива событий (установить в ON)

3. На панели, используя системные настройки >> закладка «History» >> отметить [Clear Evenlog]>

>> нажать кнопку «Clear».
После очистки файла Event log, нажмите кнопку «OK», чтобы выйти из режима.

Как очистить файл архива событий - шаг 3

Как использовать функцию защиты?

Ответ:

Приведем пример иллюстрирующий по шагам возможности функции защиты (security):

Шаг 1

Сначала создайте новый проект. Затем, в Системных настройках (System parameter settings > Security) добавьте трех пользователей (users) с разными паролями и классами.

Как использовать функцию защиты - шаг 1

Шаг 2

Настройте объекты Window_10, как показано ниже:

Как использовать функцию защиты - шаг 2

[NE_0] и [NE_1] - это объекты «Numeric input», где адреса [LW-9219] и [LW-9220] используются для ввода идентификатора пользователя (user ID) и пароля. [LW-9219] настроен на ввод ID в диапазоне 1~12, длиной в 1 слово, в формате «16-bit Unsigned», как показано ниже.

Как использовать функцию защиты - шаг 3

[LW-9220] настроен для ввода пароля пользователя (user password) длиной в 2 слова, в формате «32-bit Unsigned», как показано ниже.

Как использовать функцию защиты - шаг 4

[ND_0] - это объект «Numeric display» с адресом [LW-9222] для отображения состояния пользователя. Данные отображаются в формате «16-bit Binary».

Как использовать функцию защиты - шаг 5

[SB_0] ~ [SB_2] – это объекты «Set Bit objects», которые настроены на разные классы с дополнительной функцией “Make invisible while protected“ – Сделать невидимым, когда защищено. [SB_0] – это класс A, [SB_1] – это класс B, [SB_2] – это класс C. Настройки объекта [SB_0]:

Как использовать функцию защиты - шаг 6

[SB_3] – это класс «Set Bit» с адресом [LB-9050] для выхода пользователя из программы (logout):

Как использовать функцию защиты - шаг 7

Шаг 3

После настройки этих объектов, запустите «off-line симуляцию» проекта.

Рисунки, показанные далее, это первичный экран в режиме «off-line simulation».

В этот момент никакое имя пользователя еще не введено.

[LW-9222] показывает “0000000000000000”, означающее, что текущий пользователь может использовать только объект класса “None”.

Кроме того, [SB_0] ~ [SB_2] - это объекты с классом защиты A ~ class C и в то же время с пометкой “Make invisible while protected“, поэтому объекты [SB_0] ~ [SB_2] спрятаны системой.

Как использовать функцию защиты - шаг 8

Шаг 4

Когда пользователь введет пароль "111", экран станет таким:

Как использовать функцию защиты - шаг 9

Шаг 5

Далее, когда пользователь «3» введет пароль "333", экран станет таким:

Как использовать функцию защиты - шаг 10

Пользователю «3» is разрешено использовать объекты с классами защиты A,B,C. Затем, биты 0 ~ 3 в [LW-9222] станут «1», чтобы подтвердить, что этому пользователю разрешено использовать объекты с классами защиты A,B,C.

Шаг 6

Если будет нажата [LB9050] приводящая к выходу пользователя из системы (logout), система перейдет в первоначальное состояние. Другими словами, новый пользователь может использовать объекты только с классом защиты “None”.
Как использовать функцию защиты - шаг 11

Как использовать функцию декомпиляции?

Ответ:

1. Если Вы хотите декомпилировать файл « *.xob» в файл «*.mtp» file, выберите в меню « Tools -> Decompile»

Как использовать функцию декомпиляции - шаг 1

2. После всплытия окна «Decompile» нажмите кнопку «Browse», чтобы открыть нужный файл. Введите пароль в окошке «XOB password». (Примечание: XOB-пароль создается при компиляции проекта)

Как использовать функцию декомпиляции - шаг 2

3. Когда файл декомпилирован, пользователь может открыть файл « *.mtp» для редактирования проекта.

Как использовать функцию декомпиляции - шаг 3

Как использовать функцию выгрузки?

Ответ:

1. Нажмите кнопку “Upload” (Выгрузить) на панели «Project Manager».

Как использовать функцию выгрузки - шаг 1

2. После всплытия окна «Upload» нажмите кнопку «Browse», чтобы выбрать место сохранения файла . Укажите IP-адрес панели в окошке «HMI IP» и нажмите кнопку «Upload».

Как использовать функцию выгрузки - шаг 2

3. После окончания выгрузки, нажмите кнопку “Exit”. Будет создан выгруженный файл.

Как использовать функцию выгрузки - шаг 3

Как загрузить проект по имени панели?

Ответ:

Если пользователь хочет загружать проекты по сети Ethernet, существует два варианта. Один - это ввести IP адрес панели; Другой – ввести имя панели.

Перед загрузкой проекта по сети Ethernet, IP адрес панели должен быть установлен системных настройках панелиI. Если выбран режим “Auto Get IP Address”, IP адрес будет автоматически присваиваться локальным сервером DHCP. Если выбран режим “IP address get from below” IP адрес и другую информацию для сети надо будет вводить вручную.

Как загрузить проект по имени панели - шаг 1

Версия панели должна быть: имидж OS 20091009 или новее

Как загрузить проект по имени панели - шаг 2

Версия программы EasyBuilder: EB8000 V3.30 или более новая

Как загрузить проект по имени панели - шаг 3

1. Сначала, пользователь должен присвоить Имя панели в «System settings».

Как загрузить проект по имени панели - шаг 4

2. После присвоения имени панели, выберите закладку [Name] в окне загрузки, как показано ниже

Как загрузить проект по имени панели - шаг 5

3. Введите имя панели в поле «HMI name» и нажмите “Search”, чтобы отыскать нужную панель.

Как загрузить проект по имени панели - шаг 5

Или нажмите “Search all”, чтобы найти все панели в сети.

Как загрузить проект по имени панели - шаг 6

4. Выберите панель и нажмите кнопку «Download» для начала загрузки проекта.

Как загрузить проект по имени панели - шаг 8

Как автоматически заменить адреса ПЛК на имена тэгов (Имена тэгов Name) после конвертирования проекта EB500 в EasyBuilder Pro?

Ответ:

После конвертирования проекта EB500 в EasyBuilder Pro, имена тэгов тэгов будут потеряны. Пошаговая процедура, показанная ниже, позволяет пользователю заменить адреса ПЛК на имена тэгов импортированием библиотеки тэгов EB500 в EasyBuilder Pro.

Шаг 1.

Откройте Библиотеку Имен тэгов (Tag Library) проекта в EB500 и выберите “Export” , чтобы сохранить имена тэгов, как файл с расширением .tgl.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 1

Примечание: Не используйте функцию “ExportCSV”, она не пригодна для автоматической замены адресов ПЛК на имена тэгов.

Шаг 2.

Откройте «EasyBuilder Pro», в меню [Tool] выберите [Translate MT500 Project …] – Транслировать Проект MT500.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 2

Шаг 3.

Выберите файл в окошке «MT500 EOB file» и нажмите “Translate”.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 3

Шаг 4.

Выберите “Exit” после окончания трансляции проекта.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 4

Шаг 5.

Откройте конвертированный проект в EasyBuilder Pro.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 5

Шаг 6.

Откройте «Address Tag Library» (Библиотеку адресов тэгов) и выберите “Load Tag File” (Загрузить файл Имен тэгов).

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 6

Шаг 7.

Выберите файл EB500 с расширением .tgl.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 7

Шаг 8.

Когда появится сообщение “Use tag to represent the address” – Использовать имена тэгов представляющие адреса, нажмите «Yes».

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 8

Шаг 9.

ПЛК адреса объектов будут автоматически заменены на имена тэгов.

Автоматическая замена адреса ПЛК на имена тэгов после конвертирования проекта EB500 в EasyBuilder Pro - шаг 9

Инструкция по установке драйвера USB для панелей серии i

Ответ:

Панели MT6000/8000 серии «I» поддерживает функцию применения кабеля «USB в Mini USB» для загрузки/выгрузки проекта в компьютер. При использовании кабеля USB для загрузки проекта, компьютер выступает в качестве Ведущего устройства (Master), а панель является Клиентом.

Для использования этой функции необходимо установить EB8000 версии 2.00 или более новой (EasyBuilder Pro) и драйвер USB панели на компьютер при первом использовании этой функции.
(Панель должна быть одной из: MT6050i, MT6056i, MT6070iH, MT6100i, MT8050i, MT8070iH, MT8100i).

Примечание: драйвер USB совместим с Windows XP SP3 и Vista.

1. Подключите кабель USB мини стороной к панели, а другой к компьютеру. На экране компьютера появится диалоговое окно “Found New Hardware Wizard” – найдено новое устройство. Выберите “No, not this time” – (Не в этот раз) и нажмите” Next”.

Инструкция по установке драйвера USB для панелей серии i - шаг 1

2. Выберите “Install from a list or specific location (Advanced)” и нажмите” Next”.

Инструкция по установке драйвера USB для панелей серии i - шаг 2

3. Отметьте “Include this location in the search”, и введите путь C:\EasyBulder Pro\usbdriver, и нажмите “Next” .

Инструкция по установке драйвера USB для панелей серии i - шаг 3

4. После этого будет автоматически установлен драйвер для панелей Weintek серии «i» driver: C:\EasyBuilder Pro\usbdriver

Инструкция по установке драйвера USB для панелей серии i - шаг 4

Инструкция по установке драйвера USB для панелей серии i - шаг 4b

(Процесс инсталляции 1)

Инструкция по установке драйвера USB для панелей серии i - шаг 4c

(Процесс инсталляции 2)

5. Драйвер USB будет успешно установлен после нажатия кнопки "Finish".

Инструкция по установке драйвера USB для панелей серии i - шаг 5

6. Пользователь может перейти: Computer Management -> Device Manager, чтобы проверить, действительно ли установлен драйвер «Weintek HMI i Seires».

Инструкция по установке драйвера USB для панелей серии i - шаг 6

7. Теперь пользователь может загружать проект в панель по кабелю USB.

Инструкция по установке драйвера USB для панелей серии i - шаг 7

Поиск неисправности:

Если появилось сообщение об ошибке при загрузке проекта по кабелю USB (например, как на рисунке внизу), проверьте следующие факторы:

рис.

1. Порт USB на компьютере должен быть типа USB2.0.

2. Проверьте в: Computer Management àDevice Manager правильность установки драйвера USB. Драйвер USB поддерживается Windows XP SP3 и Vista.

3. Смените кабель USB и проверьте снова. Кабель USB должен иметь двухслойное экранирование: алюминиевая фольга и сетка из проводников.

4. Если использован настольный компьютер, кабель USB должен быть вставлен в порт на задней стороне корпуса, а не в передней, потому что кабель соединения между материнской платой и портом USB на передней стороне, обычно, выполнен не экранированным.

Выравнивание текста в объектах в EasyBuilder Pro

Ответ:

В EasyBuilder Pro, существует два различных способа выравнивания текста в объекте: один щелчком по иконке на панели инструментов «toolbar) и другой выбором в диалоге настройки объекта.

  • После выбора иконки на панели инструментов (Left Alignment | Center Alignment | Right Alignment – Выравнивание по левому краю | Выравнивание по центру | Выравнивание по правому краю), однострочный или многострочный текст будет, как одна надпись (Label), выравненная относительно очертаний объекта.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 1

  • При выборе направления выравнивания «Label>>Align» в диалоге настроек объекта, несколько строк будут выравнены соответствующим образом. Это выравнивание строка за строкой.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 2

  • Выравнивание строка за строкой многострочного текста может быть сделано, используя выбор «Label>>Attribute» в диалоге настроек объекта.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 3

  • Если объект настроен на [Left] или Align], при нажатии [Left Alignment] на панели инструментов, многострочный текст будет перемещен к левому краю объекта.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 4

  • Способ показанный выше такой же для [Align Center] и [Align Right]. Многострочный текст будет отображен в соответствии с выбором «Label>>Attribute>>Align».

На рисунке внизу при выбранной иконке [Left Alignment], содержащийся текст are still отображается так, как указано в настройках объекта.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 5

  • Если текстовый объект имеет несколько состояний, отметьте функцию [Tracking] - слежение, тогда при перемещении текста в одно состояние в другое, тексты других состояний будут перемещаться таким же образом.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 6

  • Перемещая текстовый объект в состояние 0; проверьте другие состояния, чтобы увидеть, действительно ли тексты в этих состояниях перемещаются тем же способом, как в состоянии 0. Если слежение - [Tracking] не выбрано, только текст в одном состоянии будет перемещаться.

Выравнивание текста в объектах в EasyBuilder Pro - шаг 7

Какой максимальный объем SD-карты поддерживает панель eMT3150A?

Ответ:

Максимальный объем SD-карты составляет 32Гб в формате fat32.

Как подключить панель Weintek к ПЛК Siemens S7-300/ET200S (Ethernet)

Ответ:

Руководство по соединению с ПЛК Siemens S7-300/ET200S (Ethernet)

Поддерживаемые серии:: Siemens S7-300 Ethernet Series PLC, модуль Ethernet CP-343-1, CPU315-2 PN/DP, CPU317-2 PN/DP, CPU319-3 PN/DP и ET200S.

Website:  siemens

Настройки панели (HMI):

Параметры Рекомендуемые значения Варианты Примечания
Тип ПЛК SIEMENS S7-300/ET200S (Ethernet)
Интерфейс Ethernet

Номер порта 102

Номер станции ПЛК 1 0-31

Адреса устройств:

Bit/Word Тип
устройства
Формат Диапазон Описание
B I DDDDo 0 ~ 40957 Input (I)
B Q DDDDo 0 ~ 40957 Output (O)
B M DDDDo 0 ~ 40957 Bit Memory
B DBnBit FFFFDDDDo 0 ~ 409699997
B DB0Bit-DB99Bit DDDDDo 0 ~ 655327 Data Register Bit
W IW DDDD 0 ~ 4095 Input (I)
W QW DDDD 0 ~ 4095 Output (O)
W MW DDDD 0 ~ 4095 Bit Memory
DW MD DDDD 0 ~ 4094 Bit Memory Double Word
W DBn FFFFDDDD 0 ~ 40969999 Data Register (должен
быть четным)
DW DBDn FFFFDDDD 0 ~ 40969999 Data Register Double Word (должен быть
кратным 4)
W DBn_String FFFFDDDD 0 ~ 40969999
DW DBDn_String FFFFDDDD 0 ~ 40969999
W DB0 ~ DB99 DDDDD 0 ~ 65532 Data Register (должен
быть четным)
Byte MB DDDD 0 ~ 4095 Bit Memory Byte
Byte DBBn FFFFDDDD 0 ~ 40969999 Data Register Byte

- Двойные слова и значения с плавающей запятой должны использовать тип устройства – DBDn.

Как импортировать Тэги:

Программа «SIEMENS STEP 7» позволяет создавать файлы тэгов определяемых пользователем (*.dif и *.AWL) и импортировать эти файлы в: EasyBuilder8000/EasyBuilderPro -> System Parameter Settings.

Далее описан порядок создания и импорта файлов этих двух типов:

1. Создание файла «*.dif»

a. В “Symbols” создайте тэг определяемый пользователем (user-defined tag):

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 1

b. Нажмите Export , чтобы экспортировать редактированный файл и нажмите Save.

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 1b

2. Создание файла «*.AWF»
a. В Blocks создайте элементы (items), как показано ниже:

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2

b. Откройте: LAD/STL, FBD – Programming S7 Blocks, нажмите File -> Generate Source.

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2b

c. Выберите Sources в качестве пути сохранения, укажите имя файла и нажмите OK.

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2c

d. Выберите объекты для экспорта и нажмите OK.

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2d

e. В Sources должны быть имена сохраняемых файлов. Выберите Export Source чтобы создать файл « *.AWL».

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2e

Созданные файлы « *.dif» и «.AWL» могут быть импортированы в EasyBuilder8000/EasyBuilderPro > System Parameter Settings, нажатием кнопки Import Tag.

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2f

Информация о Тэгах успешно импортирована:

Руководство по соединению с ПЛК Siemens S7-300 ET200S - шаг 2g

Схемы соединений:
Прямое соединение (перекрестный кабель - crossover):

HMI RJ45 папа Цвет провода ПЛК RJ45 папа
1 TX+ Белый / Оранжевый 3 RX+
2 TX- Оранжевый 6 RX-
3 RX+ Белый /Зеленый 1 TX+
4 BD4+ Голубой 4 BD4+
5 BD4- Белый/Голубой 5 BD4-
6 RX- Зеленый 2 TX-
7 BD3+ Белый/Коричневый 7 BD3+
8 BD3- Коричневый 8 BD3-
Руководство по соединению с ПЛК Siemens S7-300 ET200S
Руководство по соединению с ПЛК Siemens S7-300 ET200S

Соединение через коммутатор:

HMI RJ45 папа  Цвет провода ПЛК RJ45 папа
1 TX+ Белый / Оранжевый  1 TX+
2 TX- Оранжевый 2 TX-
3 RX+ Белый /Зеленый 3 RX+
4 BD4+ Голубой 4 BD4+
5 BD4- Белый/Голубой 5 BD4-
6 RX- Зеленый 6 RX-
7 BD3+ Белый/Коричневый 7 BD3+
8 BD3- Коричневый 8 BD3-
Руководство по соединению с ПЛК Siemens S7-300 ET200S

Руководство по соединению с ПЛК Siemens S7-300 ET200S

Версия драйвера:

Версия Дата Описание
V2.10 May/21/2011 Добавлены регистры:
MB & DBBn

Характеристики USB- кабеля панелей - i серии

Ответ:

Спецификация USB - кабеля : HI-SPEED USB Revision 2.0 SHIELDED 24AWG

Примечание:

1. USB порт компьютера должен поддерживать стандарт USB2.0

2. Кабель USB должен иметь двухслойное экранирование: алюминиевая фольга и сетка из проводников.

Характеристики USB- кабеля панелей i-серии - рисунок 1

3. Длина USB- кабеля не должна быть большой. 1 метр – это нормально.

4. Если использован настольный компьютер, кабель USB должен быть вставлен в порт на задней стороне корпуса, а не в передней, потому что кабель соединения между материнской платой и портом USB на передней стороне, обычно, выполнен не экранированным.

5. При загрузке проекта по USB, не соединяйте ПЛК с COM- портом панели или используйте загрузочный кабель RZCMT6100 панелей MT6000/8000 i серий для загрузки, чтобы защитить панель от возможного повреждения..
6. Если загрузка проекта не выполнилась, причиной может быть несовместимость драйвера USB. Используйте другой компьютер или проверьте правильность установки драйвера на ПК, как показано на рисунках внизу..

Характеристики USB- кабеля панелей i-серии - рисунок 2

Характеристики USB- кабеля панелей i-серии - рисунок 3

Установка пароля на Выгрузку/Загрузку проекта панелей MT6000/8000

Ответ:

Панели серий MT6000/8000 обеспечивают надежную защиту при помощи пароля (password protection). При изготовлении панели устанавливают первичный пароль 111111. Пользователь может установить свой собственный пароль следующим образом:

1. Нажмите на иконку “<” в нижнем правом углу экрана, откроется панель системных настроек (system setting). Нажмите на иконку “Setting”, всплывет окно с запросом на ввод пароля пользователя.

Установка пароля на Выгрузку/Загрузку проекта панелей MT6000/8000 - рис. 1

2. Введите пароль. По умолчанию “111111”. Click “OK” and the “System Settings” window shows up.

Установка пароля на Выгрузку/Загрузку проекта панелей MT6000/8000 - шаг 2

3. Перейдите к закладке “Security”, в которой находятся четыре вида паролей и их можно изменять, как показано на рисунке внизу:

Установка пароля на Выгрузку/Загрузку проекта панелей MT6000/8000 - шаг 3

Local Password – Местный пароль

Пароль необходим для входа в режим настройки системных параметров - “System Settings”;

UploadPassword – Пароль для выгрузки

Пароль необходим для выгрузки проекта;

Download Password – Пароль для загрузки

Пароль необходим для загрузки проекта;

Upload (History) Password - Пароль для выгрузки архивов

Пароль необходим для выгрузки файлов архивов данных и событий (data / event log file);

4. При выборе “Upload Password” всплывет диалоговое окно. Введите новый пароль дважды. Сравните (Comparing) два пароля, если они одинаковые, появится сообщение “Password match” – Пароли одинаковые. Иначе, появится сообщение “Password NOT match !” message will show up. Нажмите “OK”, чтобы завершить действие.

Установка пароля на Выгрузку/Загрузку проекта панелей MT6000/8000 - шаг 4

Нажмите “Apply”, чтобы активировать новый пароль. В следующий раз, когда пользователь захочет выгрузить проект, он должен будет ввести новый пароль.

Все четыре вида паролей могут быть модифицированы таким же способом.

Убедитесь в том, что Вы ввели корректный пароль для работы панелей MT6000/MT8000. EasyBuilder Pro будет использовать тот же самый пароль для выгрузки/загрузки проекта.

Удаленное соединение панели MT8000 с iPhone

Ответ:

1. Настройте функцию VNC в панели MT8000, как описано в ЧЗВ «Как использовать VNC сервер» на сайте www.weintek.com

Или в FAQ на сайте изготовителя:

FAQ_28_How_to_use_VNC_server.pdf

2 Откройте App Store и найдите “VNC”. Далее найдите и установите “Mocha VNC Lite”

Удаленное соединение панели MT8000 с iPhone - рис. 1

3. В «Mocha VNC Lite» установите IP адрес панели, Пароль, TCP порт = 5900. Нажмите “Connect” и пользователь может управлять панелью при помощи iPhone.

Удаленное соединение панели MT8000 с iPhone - рис. 2

Рабочая температура панелей?

Ответ:

Диапазон рабочей температуры панелей MT6000/8000 HMI от 0° до 45°C (32°~113°F). Если панель находится в среде с температурой ниже 0°C или выше допустимой, пластмасса может расшириться на жаре или сжаться на холоде. Когда панель неожиданно испытывает большие изменения температуры encounters, пластик корпуса панели (лицевая рамка и задняя крышка) могут деформироваться. Деформация лицевой рамки приведет к отказу сенсорного экрана, так как сенсорный экран приклеен к лицевой рамке и может быть тоже.

Поэтому мы категорически рекомендуем пользователям поддерживать температуру, установив нагреватель в шкафу с панелью при температуре 0°C или установить кондиционер/вентилятор для отвода тепла при температуре свыше 45°C.

Порты TCP панели MT8000

Ответ:

Список портов MT8000 приведен ниже.

● Remote HMI TCP port = 8000 (Порт удаленного управления панелью)

Порты TCP панели MT8000 - рис. 1

● Загрузка проекта через маршрутизатор (router)

MT8000 Project download TCP port = 20248 (Порт загрузки проекта)

При необходимости загрузки проекта через Internet, убедитесь, сначала, в том, что Ваш маршрутизатор поддерживает виртуальный сервер или переадресацию порта (forwarding).

Порты TCP панели MT8000 - рис. 2

● VNC Viewer TCP port = 5900 (Порт для программы просмотра VNC)

● http VNC, Java (Порты для работы с VNC, Java)

TCP port = 80

TCP port = 5800

● Ethernet Pass-Thru TCP port = 2000 (Проходной порт)

● Printer Server TCP port = 8005 (Порт сервера печати)

Порты TCP панели MT8000 - рис. 3

● Modbus TCP/IP порт = 502

Порты TCP панели MT8000 - рис. 4

Пользовательский стартовый экран панелей i-серии

Ответ:

Сенсорные панели версии «i» разрешают пользователю создаватьuser свой собственный стартовый экран (startup screen), содержащий, например, логотип компании и т. п.. Для использования этой возможности проделайте следующие шаги:

Примечание: Эту функцию поддерживают только панели серии «i».

1. Версия фирменного программного обеспечения панели должна быть: 20090415 или новее :

Пользовательский стартовый экран панелей i-серии - шаг 1

2. Версия программы EasyBuilder8000 должна быть: V3.20 2009.07.30 или новее:

Пользовательский стартовый экран панелей i-серии - шаг 2

3. Запустите программу Project Manager program, нажмите кнопку “Download”:

Пользовательский стартовый экран панелей i-серии - шаг 3

4. При открытии окна “Download”, выберите “Startup screen”, и Нажмите кнопку “Browse…”. Выберите изображение, которое Вы хотите использовать в качестве стартового экрана панели.

Пользовательский стартовый экран панелей i-серии - шаг 4

5. Нажмите кнопку “Download”. После загрузки, сделайте рестарт панели. Стартовый экран будет
уже с измененным пользователем изображением..

Пользовательский стартовый экран панелей i-серии - шаг 5

Обновление имиджа ОС панелей MT8000/6000

Ответ:

Имидж Операционной Системы (ОС) панелей MT8000/6000 версии 20081013 и новее, поддерживает использование USB-диска или SD-карты для обновления имиджа ОС.

Процесс обновления (Upgrade) подобен загрузке проекта в панель. В примере показано, как обновить имидж ОС при помощи USB-диска.

1. Найдите соответствующий файл имиджа ОС для MT8000/6000 и скопируйте его на USB-диск.
(Как показано на рисунке 1). Например, скопируйте его в предварительно созданную папку «001».

Обновление имиджа ОС панелей MT8000/6000 - шаг 1

<< Рисунок 1 >>

2. Вставьте USB-диск в USB порт MT8000/6000.

3. Переместите курсор в нижний левый угол экрана. Появится кнопка “<” (как показано на рисунке 2), нажмите на неё, чтобы открыть панель системных настроек

(как показано на рисунке 3).

Обновление имиджа ОС панелей MT8000/6000 - шаг 3

<< Рисунок 2 >>

Обновление имиджа ОС панелей MT8000/6000 - шаг 3

<< Рисунок 3>>

4. Нажмите кнопку “setup”, всплывет окно для ввода пароля (как показано на рисунке 4).

Обновление имиджа ОС панелей MT8000/6000 - шаг 4

<< Рисунок 4 >>

5. Введите пароль (пароль по умолчанию: 111111), всплывет окно системных настроек

“System settings”. Выберите закладку “Upgrade firmware” - обновить (как показано на рисунке 5).

Обновление имиджа ОС панелей MT8000/6000 - шаг 5

<< Рисунок 5 >>

6. Нажмите кнопку “Upgrade firmware” button, a “Pick a Directory” popup window will show up (как показано на рисунке 6).

Обновление имиджа ОС панелей MT8000/6000 - шаг 6

<< Рисунок 6 >>

7. Откройте папку «usbdisk», выберите папку «001»,затем нажмите кнопку “OK”.

8. Начнется обновление имиджа ОС. Процесс занимает несколько минут. Состояние процесса отражается в окне (как показано на рисунке 7).

Обновление имиджа ОС панелей MT8000/6000 - шаг 7

<< Рисунок 7 >>

9. После окончания обновления ОС, система автоматически рестартует; рекомендуется после этого сделать калибровку сенсорного экрана.

Как использовать VNC сервер?

Ответ:

1. В системных настройках активируйте VNC-сервер, для этого в закладке «VNC server» нажмите «Start VNC» и установите пароль на вход в VNC (login).

Использование VNC сервера - шаг 1

2. Установите на компьютере Java для Internet Explorer или установите «VNC viewer».

Java web site:  http://java.com

VNC viewer:  ftp://ftp.weintek.com/MT8000/utility/vnc-4_1_2-x86_win32_viewer.zip

VNC viewer для Pocket PC:

ftp://ftp.weintek.com/MT8000/utility/zoomVNC.CAB

http://zoomvnc.com/

3. Выполните «IE» и введите IP адрес панели: http://192.168.1.28 (например)

Использование VNC сервера - шаг 2

Или запустите «VNC viewer», и введите IP адрес панели и пароль.

Использование VNC сервера - шаг 3

Примечание:

(1) Возможен вход в VNC только одного пользователя одновременно.
(2) Панель будет отключать соединение с VNC, если никаких операций не будет произведено в течении одного часа.

Как активировать / отключить панель системных настроек

Ответ:

EasyBuilder Pro поддерживает функцию активирования/отключения панели системных настроек (enable/disable system setting bar) с использованием системного тэга [LB-9020] или с использованием переключателя [DIP Switch 2] для управления этой функцией.

При использовании [LB-9020] для управления панелью системных настроек, если LB-9020 в состоянии «ON», панель отображается, а состояние «OFF»прячет панель системных настроек.

При переводе переключателя [DIP Switch 2] в состояние «ON», панель системных настроек отключается, а когда [DIP Switch 2] в состоянии «OFF», панель системных настроек можно использовать. Пользователь должен рестартовать панель, чтобы активировать / отключить эту функцию.

DIP Switch 2

Примечание:

[LB-9020] - доступно для панелей серий MT6000/8000 T, X, i.

[DIP Switch 2] - есть у панелей серий MT6000/8000i и XV2.

Замена батарейки в панелях серий «Х» и «i»

Ответ:

В панелях серий MT-600X / MT8000X / MT8000i используются литиевые батарейки типа CR2032 для поддержания работы часов реального времени (RTC) running.

Спецификация батарейки: CR2032 3V литиевая батарейка.

Для замены батарейки:

  1. Выключите экран и откройте заднюю крышку.
  2. Используйте отвертку, чтобы вынуть батарейку из гнезда.
  3. Вставьте новую батарейку в гнездо.
  4. Закройте заднюю крышку.
  5. Присоедините USB – клавиатуру на панели
  6. После перезагрузки панели, введите [Delete], для доступа к окну настроек.
  7. В окне настроек выберите [CMOS Feature] для настройки времени и даты.
  8. Перейдите [Load optimized default] => нажмите «yes» =>затем «Enter» => нажмите F10 для сохранения настроек.

Правильный способ установки новой батарейки

Правильный способ установки новой батарейки

Примечания:

1. До установки батарейки в панелях MT8000i сохраните данные рецептов, используя ProjectManager.

2. Напряжение батарейки (Reading Battery Voltage) в EasyBuilder Pro можно прочитать в LW9008 (в формате 32бит с плавающей запятой).

Если напряжение меньше 2.8 В, необходимо заменить батарейку.

Загрузка / Выгрузка проекта с USB-накопителя

[Загрузка проекта - Download]

Шаг1. Вставьте USB-накопитель в порт компьютера.

Шаг2. В EB8000, перейдите > [Tools] / [Build Data for USB Disk or CF card Download…]

Загрузка проекта с USB-накопителя - шаг 2

Шаг 3. Присвойте имя папки или нажмите [Browse] для сохранения проекта, затем нажмите [Build]

Загрузка проекта с USB-накопителя - шаг 3

Шаг 4. После сохранения проекта в USB-накопителе, появится сообщение об успешном завершении.

Загрузка проекта с USB-накопителя - шаг 4

Шаг 5. Вставьте USB-накопителе в порт панели, появится диалоговое окно «Download/Upload», нажмите [Download].

Загрузка проекта с USB-накопителя - шаг 5

Шаг 6. Введите пароль для загрузки и нажмите [OK]

Загрузка проекта с USB-накопителя - шаг 6

Шаг 7. Выберите «usb disk» -> нажмите папку «usb» -> нажмите [OK], чтобы загрузить проект

Загрузка проекта с USB-накопителя - шаг 7

Шаг 8. Загрузка файлов проекта…

Загрузка проекта с USB-накопителя - шаг 8

Шаг 9. После успешного завершения загрузки, проект будет отображен на экране панели оператора.

Загрузка проекта с USB-накопителя - шаг 9

[Выгрузка проекта - Upload]

Шаг 1. Вставьте USB Disk в порт панели, появится диалоговое окно «Download/Upload», нажмите [Upload].

Выгрузка проекта с USB-накопителя - шаг 1

Шаг 2. Введите пароль на выгрузку и нажмите [OK]

Выгрузка проекта с USB-накопителя - шаг

Шаг 3. Выберите «usb disk» -> нажмите на папку «usb», чтобы сохранить файл в этой папке -> нажмите [OK]. Чтобы выгрузить проект.

Выгрузка проекта с USB-накопителя - шаг 3

Шаг 4. Выгрузка файлов проекта…

Выгрузка проекта с USB-накопителя - шаг 4

Шаг 5. Вставьте USB Disk в компьютер, перейдите к «001» и добавьте суффикс “xob” к «mt8000».

Выгрузка проекта с USB-накопителя - шаг 5

Шаг 6. Перейдите в EasyBuilder Pro -> Tools -> Decompiles…

Выгрузка проекта с USB-накопителя - шаг 6

Шаг 7. Выберите «mt8000.xob» в «USB disk» и нажмите [Decompile] – Декомпилировать.

Выгрузка проекта с USB-накопителя - шаг 7

Шаг 8. После успешной декомпиляции, нажмите «exit» и откройте фал «.mtp» в «USB disk».

Выгрузка проекта с USB-накопителя - шаг 8

Шаг 9. Конец процедуры выгрузки.

Задать вопрос
Имя
Контактный телефон
E-mail
Компания
Ваш вопрос
Защитный код:Введите защитный код:
Нажимая кнопку «Отправить», я соглашаюсь с условиями Политики конфиденциальности
Запрос цены
Товар
Имя
Компания
Контактный телефон
E-mail
Комментарий
Защитный код:Введите защитный код:
Нажимая кнопку «Отправить», я соглашаюсь с условиями Политики конфиденциальности
Запрос цены
Ваш запрос успешно отправлен!