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I SCADAPack E Target 5 Quick Start Guide

©2013 Control Microsystems Inc. 
All rights reserved.
Printed in Canada.

Version: 8.05.4

The information provided in this documentation contains general descriptions and/or technical
characteristics of the performance of the products contained herein. This documentation is
not intended as a substitute for and is not to be used for determining suitability or reliability of
these products for specific user applications. It is the duty of any such user or integrator to
perform the appropriate and complete risk analysis, evaluation and testing of the products
with respect to the relevant specific application or use thereof. Neither Schneider Electric nor
any of its affiliates or subsidiaries shall be responsible or liable for misuse of the information
contained herein. If you have any suggestions for improvements or amendments or have
found errors in this publication, please notify us.

No part of this document may be reproduced in any form or by any means, electronic or
mechanical, including photocopying, without express written permission of Schneider
Electric.

All pertinent state, regional, and local safety regulations must be observed when installing and
using this product. For reasons of safety and to help ensure compliance with documented
system data, only the manufacturer should perform repairs to components.

When devices are used for applications with technical safety requirements, the relevant
instructions must be followed. Failure to use Schneider Electric software or approved
software with our hardware products may result in injury, harm, or improper operating results.

Failure to observe this information can result in injury or equipment damage.

1 Technical Support

Support related to any part of this documentation can be directed to one of the following
support centers.

Technical Support: The Americas

Available Monday to Friday 8:00am – 6:30pm Eastern Time
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Toll free within North America 1-888-226-6876

Direct Worldwide +1-613-591-1943

Email TechnicalSupport@controlmicrosystems.com

Technical Support: Europe

Available Monday to Friday 8:30am – 5:30pm Central European Time

Direct Worldwide +31 (71) 597-1655

Email euro-support@controlmicrosystems.com

Technical Support: Asia

Available Monday to Friday 8:00am – 6:30pm Eastern Time (North America) 

Direct Worldwide +1-613-591-1943

Email TechnicalSupport@controlmicrosystems.com

Technical Support: Australia

Inside Australia 1300 369 233

Email au.help@schneider-electric.com

2 Safety Information

Read these instructions carefully, and look at the equipment to become familiar with the
device before trying to install, operate, or maintain it. The following special messages may
appear throughout this documentation or on the equipment to warn of potential hazards or to
call attention to information that clarifies or simplifies a procedure.

The addition of this symbol to a Danger or Warning safety label
indicates that an electrical hazard exists, which will result in personal
injury if the instructions are not followed.

This is the safety alert symbol. It is used to alert you to potential
personal injury hazards. Obey all safety messages that follow this
symbol to avoid possible injury or death.

DANGER

mailto:TechnicalSupport@controlmicrosystems.com
mailto:euro-support@controlmicrosystems.com
mailto:TechnicalSupport@controlmicrosystems.com
mailto:au.help@schneider-electric.com
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DANGER indicates an imminently hazardous situation which, if not avoided, will
result in death or serious injury.

WARNING

WARNING indicates a potentially hazardous situation which, if not avoided, can
result in death or serious injury.

CAUTION

CAUTION indicates a potentially hazardous situation which, if not avoided, can
result in minor or moderate injury.

CAUTION

CAUTION used without the safety alert symbol, indicates a potentially hazardous
situation which, if not avoided, can result in equipment damage..

PLEASE NOTE

Electrical equipment should be installed, operated, serviced, and maintained only by qualified
personnel. No responsibility is assumed by Schneider Electric for any consequences arising
out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction and
operation of electrical equipment and the installation, and has received safety training to
recognize and avoid the hazards involved.

BEFORE YOU BEGIN

SCADAPack Workbench and SCADAPack E Smart RTU are not suitable for controlling
safety-critical systems. SCADAPack Workbench and SCADAPack E Smart RTU are not
tested for, nor have approval for use in, the control of safety-critical systems. Safety-critical
systems should be controlled by an approved safety-critical platform that is independent of
SCADAPack Workbench and SCADAPack E Smart RTU. 

WARNING

UNINTENDED EQUIPMENT OPERATION

Do not control safety-critical systems with SCADAPack Workbench and
SCADAPack E Smart RTU. 

Failure to follow these instructions can result in death, serious injury or
equipment damage.

Do not use this product on machinery lacking effective point-of-operation guarding. Lack of
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effective point-of-operation guarding on a machine can result in serious injury to the operator
of that machine.

CAUTION

EQUIPMENT OPERATION HAZARD

Verify that all installation and set up procedures have been completed.

Before operational tests are performed, remove all blocks or other temporary
holding means used for shipment from all component devices.

Remove tools, meters, and debris from equipment.

Failure to follow these instructions can result in injury or equipment
damage.

Follow all start-up tests recommended in the equipment documentation. Store all equipment
documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and grounds, except those
grounds installed according to local regulations (according to the National Electrical Code in
the U.S.A, for instance). If high-potential voltage testing is necessary, follow
recommendations in equipment documentation to prevent accidental equipment damage.

Before energizing equipment:

Remove tools, meters, and debris from equipment.

Close the equipment enclosure door.

Remove ground from incoming power lines.

Perform all start-up tests recommended by the manufacturer.

OPERATION AND ADJUSTMENTS

The following precautions are from the NEMA Standards Publication ICS 7.1-1995 (English
version prevails):

Regardless of the care exercised in the design and manufacture of equipment or in the
selection and ratings of components, there are hazards that can be encountered if such
equipment is improperly operated.

It is sometimes possible to misadjust the equipment and thus produce unsatisfactory or
unsafe operation. Always use the manufacturer’s instructions as a guide for functional
adjustments. Personnel who have access to these adjustments should be familiar with the
equipment manufacturer’s instructions and the machinery used with the electrical
equipment.

Only those operational adjustments actually required by the operator should be accessible
to the operator. Access to other controls should be restricted to prevent unauthorized
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changes in operating characteristics.
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3 Overview

This document is a guide to help new users configure, program and operate a SCADAPack E
Smart RTU. This guide covers SCADAPack E Target 5 programming.

The simple tasks presented in this guide therefore do not include important user information
necessary for the control of real life applications.  This guide is not a substitute for the
SCADAPack E Target 5 Help and SCADAPack E Technical Reference Manuals, but rather is
a companion to these publications. For a thorough treatment of IEC 61131-3 fundamentals, it
is recommended that the user consult these manuals.

In this manual, the user is guided through the task of creating a sample Function Block
Diagram program, compilation of the program, connecting to the SCADAPack E Smart RTU
and downloading the compiled program.

Assumed Knowledge

Exposure to SCADAPack Workbench is recommended.  

Target Audience

Systems Engineers

Commissioning Engineers

Maintenance Technicians

References

Workbench Help

SCADAPack E Target 5 Help

SCADAPack E Technical Reference Manuals.

Hardware Requirements

The following hardware items are recommended to perform the tasks in this manual:  

SCADAPack E Installation DVD.

SCADAPack E Smart RTU – Check the nominal operational voltage.

A 12Vdc/1.1A or 24 VDC/0.55A power supply depending on RTU requirement.

RJ to DB-9 crossed cable.

Windows PC or laptop with the following hardware requirements:

Microsoft Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008,
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or Windows 7, on 32-bit or 64-bit Operating System

1 GB free disk space

Minimum: 1.6 GHz CPU, 1 GB RAM, 1024x768 display, 5400 RPM hard disk

Recommended: 2.2 GHz or higher CPU, 2 GB or more RAM, 1280x1024 display, 7200
RPM or higher hard disk 

Mouse (or other pointing device)

Ethernet port

CD-ROM drive

One (1) RS-232 serial communication port. A USB-to-RS-232 adapter will be required if
PC or laptop is only equipped with a USB port.

3.1 Licensing the Workbench

A license is required to build applications. There are 4 license types for the Workbench
application of varying duration:

One month

6 months

12 months

Unlimited

To validate your license;

1. Click Help > Licensing Target 5 CAM.

2. Review the license displayed at the bottom. In the sample Workbench License Page
below, note the Expiration date  in the "License issued by" group.
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3. Record the number in the User Code 1 field.

4. Record the number in the User Code 2 field.

5. Record the number in the User Code 3 field. 

6. Submit all User Codes to  Technical Support . You will receive Registration Key 1 and
Registration Key 2.

7. Enter the Registration Codes in their respective fields on the  Workbench licensing page.

8. Click Validate to validate your Engineering License.

If Workbench is not licensed, contact Technical Support . You can continue creating your
application without a license, but you cannot build or download the application until the license
activated.

When time-limited licenses expire you can continue creating your application without a
license, but you cannot build or download the application until a new license is obtained.

3.2 Supported Languages

SCADAPack E Target 5 supports four standard IEC 61131-3 programming languages. These
languages may be mixed within an application to provide an optimum control strategy. The
supported programming languages are described below.

Sequential Function Chart (SFC) 

The Sequential Function Chart is a graphic language used to describe sequential operations

3

3
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in a process. The process is graphically partitioned into a set of well-defined steps containing
actions performed using other languages. Steps are linked together with conditional
transitions. This language is useful for batch processes and process procedures such as
automatic startup and shut down.

Functional Block Diagram (FBD) 

The Function Block Diagram is a graphic language used to build complex procedures from a
library of functions. Standard library functions such as math and logic may be combined with
custom library functions such as serial port control, PID controls and Modbus master and
slave protocols to create Function Block Diagram application programs. A class of programs
called functions allows the creation of user functions that are not included in the library.

Ladder Diagram (LD) 

Ladder Diagram is a graphic language combining contacts and coils to build logical discrete
control procedures. This language is identical to the relay ladder logic used by many
programmable Logic RTUs. Ladder Diagram contacts and coils may be used in the Function
Block Diagram language for discrete control of functions.

Structured Text (ST)

Structured Text is a high-level structured language, similar to Pascal and C, that is used for
complex procedures or calculation that cannot be easily implemented using graphic
languages. Structured Text is the default language used to describe actions within the steps
of the Sequential Function Chart language. 

3.3 Functions and I/O Devices

SCADAPack E Target 5 includes functions to support the SCADAPack E Smart RTU. These
functions interface to the RTU point database, RTU communication parameters, serial ports,
operating system facilities, file system, time services, PID controls, and peer-to-peer
communications.

SCADAPack E Target 5 supports I/O devices for SCADAPack E RTU database, Modbus
devices and DF1 PLCs. The I/O Devices dialog is used to add selected devices to the IEC
61131-3 logic. Any combination of I/O devices may be selected up to the maximum number
of I/O points supported by the SCADAPack E Smart RTU. Each input or output point is
referenced with a variable name. IEC 61131-3 variables are updated continuously with data
from the external I/O devices. 
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4 Configuring the RTU

The SCADAPack E Smart RTU must be configured to communicate with Workbench using
SCADAPack E Configurator.

The RTU may support a serial or Ethernet communication link. To connect to the RTU via a
serial connection, one of the RTU serial ports needs to be set for ISaGRAF. To connected to
the RTU via an Ethernet connection, the ISaGRAF/TCP Service needs to be enabled.

In this example, a serial communication link will be used.  Refer to the SCADAPack E
Configurator User Manual for complete information on TCP/IP configuration and operation. 

Creating a Configuration File

A configuration file holds the settings for the RTU.

Select Start > All Programs > Schneider Electric SCADAPack E > Configurator

Select Create a new RTU configuration and click Next.

Select the RTU and model you are using.

Select Target 5 for the ISaGRAF target type. The SCADAPack E Smart RTU provides two
IEC 61131-3 target types, called Target 3 and Target 5. Target 3 is used with 16-bit
ISaGRAF Workbench (not covered by this document) and Target 5 with SCADAPack
Workbench (covered by this document).

Click Finish.

Configuring RTU Communication Ports

A RTU serial port must be configured to communicate with Workbench.

In the settings tree, open the Ports folder.

Select Ports 0-3

Configure one of the serial ports for DNP3. An example is shown below.

Configure one of the serial ports for ISaGRAF. An example is shown below.
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Configuring PC Communication Port

The PC serial port must be configured to communicate with the RTU.

Select Communication > Communication Type

For Type select Serial.

For Target DNP3 Address type the address of the RTU. Use 0 if the address has not
previously been set.

Click OK

Select Communication > Communication Settings

For Port select the serial port on the PC that is connected to the RTU.

Click OK

Select File > Save and save the configuration file.

Writing Configuration to the RTU

The configuration is written to the RTU to configure the RTU serial ports and other settings.
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Connect the RS-232 cable from the PC to the DNP3 port on the RTU.

Click the Write Configuration button  on the toolbar

Click Yes. Wait while the configuration is written to the RTU.

When prompted to restart the RTU, click Yes.

Click the Disconnect button  on the toolbar to disconnect SCADAPack E Configurator
from the RTU. This step is necessary to allow Workbench to use the PC communication
port. If you have more than one communication port on the PC connected to the RTU, then
you can leave SCADAPack E Configurator connected.

If the yellow communication status light on the bottom right-hand corner of the Ports page
remains lit, indicating communications is not occurring, please refer to the SCADAPack E
Configurator User Manual.

The RTU is now ready to communicate with Workbench on the ISaGRAF port.

5 Programming with SCADAPack Workbench

This section guides you through creating a simple application and downloading the compiled
program to the SCADAPack E Smart RTU. A sample application which cycles through the
first four digital output channels on the RTU at a controlled frequency will be created. The
frequency at which the output LEDs are cycled is controlled by a potentiometer attached to
one of the analog input ports of the RTU. 

Creating an IEC 61131-3 application comprises the following steps:

Configuring communication with the RTU

Creating an application solution file 

Adding variables

Adding and editing programs

Connecting variables to physical I/O

Building the solution

Configuring the communication ports on the RTU

Writing the solution to the RTU

Monitoring operation of the application online with the RTU

The following sections guide you through this process.
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5.1 Application Structure

A IEC 61131-3 application is called a Solution in Workbench.

A Solution for a IEC 61131-3 application contains a Project. 

A Project contains a Device, which is a SCADAPack E Smart RTU. The example above
shows a SCADAPack 300E RTU.

A Device can contain one or two Resources. Resources are independent parts of the
application. Resources can be stopped, downloaded, uploaded, and started independently. A
Resource contains IEC 61131-3 programs (also called Program Organization Units or
POUs), I/O devices, functions, function blocks, and variables. Resources can exchange
information through variable binding. These are explained in the sections that follow.

This solution structure is used for SCADAPack Workbench applications. Although it's
possible to structure the solution in other ways, they are not supported by the SCADAPack E
Smart RTU.

5.2 Creating a Solution

Programming the RTU starts by creating a solution to contain the application.

Run the SCADAPack Workbench.

From the Start Page, click New Project. If the Start Page isn't open, select File > New >
Project.

From the Installed Templates tree select SCADAPack.

In the middle panel, select the model of RTU you are using and the type of connection.

Select the Name field and type the name of the project, for example SCADAPackSample.
The same name will also be given to the Solution.
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Click OK to create the solution file.

Workbench will open the Deployment View for the solution. This view allows you to
configure communication with the RTU. This will be explained in more detail in the 
Configuring Communication with the RTU  section.

The Solution Explorer shows the solution. It should look like this. Click on the plus symbols to
expand the tree if necessary. The solution contains two resources. Only Resource1 will be
used in this example. The second resource can be left in the solution, or it can be deleted.

Adding a Program

A resource will contain one or more programs (also called Program Organization Units or
POUs). To enter a program:

Under Resource1, right-click on Programs.

Select Add > New FBD: Function Block Diagram. A new program called Prog1 is
created in the Programs group.

Double-click on Prog1 to open the Function Block Diagram (FBD) editor.

23
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5.3 Adding Variables

Variables used within a program need to be defined for the program to compile successfully. 
The following variables are used in the sample FBD program. 

Name Data Type Direction Comment

Counter INT Var Counter of the LED to turn on: 0 to (number of
LEDs - 1)

SpeedControl REAL VarInput Speed control analog input (in milliseconds)

Switch1 BOOL VarInput Enables toggling of the outputs

Led1 BOOL VarOutput Output 1

Led2 BOOL VarOutput Output 2

Led3 BOOL VarOutput Output 3

Led4 BOOL VarOutput Output 4

The variable's Data Type determines what kind of information can be stored in the variable.

The variable’s Direction defines its relationship to physical I/O.  

A variable with a Var direction is internal and is not attached to physical I/O.  

A variable with an VarInput direction is attached to a physical input.  

A variable with a VarOutput direction is attached to a physical output. 

DNP3 points (input, output or derived) defined within the point database of the SCADAPack E
Smart RTU are considered as physical I/O external to Workbench.  As a result, variables that
need to be attached to the RTU point database need to be assigned a VarInput or VarOutput
direction.

To define the variables for Prog1:

If necessary, click on the + symbol beside Prog1 to expand the tree.

Double-click on Local Variables to open the variables editor.
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Click in the empty line at the end of the table.

Type the Name of the variable and press Tab.

Type or select the Data Type of the variable and press Tab.

Press Tab twice to move the the Comment field. 

Type the comment and press Tab.

Press Tab to move the the Direction field. 

Type or select the Direction of the and press Enter.

Save the application by selecting File > Save All.

The Local Variables also contains instances of the function blocks used in the program. After
the sample program is entered there will be the BLINK_1 and R_TRIG_1 function block
instances in the local variables.

5.4 Editing Programs

SCADAPack E Target 5 supports four programming languages. This example uses a
function block program. The editors for other program types are similar. See the Workbench
Help for a full description of the editor.

To add a function block, variable, or other program elements:

Double-click on Prog1 to open the Function Block Diagram (FBD) editor.
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The Toolbox contains program elements that can be added.

Click on Block in the Toolbox.

Drag the block to the editor. The Block Selector dialog will open.

Select the block to be added.

Click OK.

To connect elements:

Move the mouse to the connector on one element.

Click and drag to the connector on the second element.

To invert the state of a BOOL link:

Select the link

In the Properties dialog set Is Negation to True.
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Sample Program

Using the FBD editor, enter the sample FBD program shown below. 
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Save the application by selecting File > Save All.

5.5 Connecting Physical I/O

Input and output variables need to be tied to an input or output I/O device. This provides a
connection between the IEC 61131-3 resource and the point database or other PLC devices.

Variables are connected to the point database within the SCADAPack E Smart RTU using
RTU_xxxx I/O devices. 
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Variables are connected to a Modbus PLC using MBUS_xxxx, MRTUTCP_xxxx, and
MTCP_xxxx I/O devices.

Variables are connected to a DF1 PLC using DF1_xxxx I/O devices.

The variables used in the sample program must be connected to physical points on the RTU.
First add an I/O device, then wire the variables to it.

To add an I/O device:

Right-click on Resource1 and select I/O Device to open the I/O device editor.

Click on the Add Device icon to open the Device Selector dialog. 

Select the RTU_BIN_READ device from the list. This board type connects variables to
binary input points in the point database.

Set the number of channels to 1. There is only one input variable in the sample program.
(Channels may be left unwired if needed, so a larger number of channels could be used.)

Click OK.

To wire variables to the I/O device:

Select the input on the device where you want to wire the variable.
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Click on the drop down arrow in the variable list (step 2 below)

Select the variable. For the RTU_BIN_READ I/O device select the Switch1@Prog1
variable.

Wire the remaining variables as follows.

Add an RTU_BIN_WRITE device with 4 channels and wire Led1, Led2, Led3, and Led4 to
the channels. This device connects variables to binary output points.

Add an RTU_ENG_READ device with 1 channel and wire SpeedControl to the channel.
This device connects variables to analog (engineering value) input points.

Save the application by selecting File > Save All.

5.6 Configuring Serial Communication with the RTU

Communication settings between the Workbench and the RTU must be configured before
building the solution.

To configure serial communication settings:

Double-click Deployment.isadpl in the Solution Explorer.
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Right-click on the Serial communication link in the deployment view and select Properties.

Edit the serial communication settings as shown below. Set Port to the serial port on your
PC that is connected to the RTU.

5.7 Configuring Ethernet Communication with the RTU

Communication settings between the Workbench and the RTU must be configured before
building the solution.

To configure ethernet communication settings:

Double-click Deployment.isadpl in the Solution Explorer.

Right-click on the LAN communication link in the deployment view and select Properties.
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Edit the TCP communication settings as shown below. Set IPAddress to the IP address of
the RTU.

TCP/IP Communications Server

SCADAPack Workbench communications to the SCADAPack E RTU's ISaGRAF TCP/IP
communications server may be established via the RTU's Ethernet interface or a serial PPP
interface.

This connection requires that the RTU has the ISaGRAF/TCP service enabled as shown in
the figure below (See the SCADAPack E Configurator TCP/IP page).
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SCADAPack E  Con figu rator

Enabled TCP/IP Services

5.8 Building the Solution

Building the solution compiles the programs, check for conditions preventing a successful
build, and prepares the solution to be downloaded to the RTU. 

To build the solution do any one of the following:

Select Build > Build Solution from the menu

Press Ctrl + Shift + B.

Click the Build Solution button on the Build toolbar

The build results are shown in the Output window at the bottom of the screen. A window will
open if there are any conditions preventing a successful build of the application. Correct the
reported items and build again.
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The solution is now ready to be written to the RTU.

5.9 Writing the Solution to the RTU

To write the solution to the RTU:

Connect the RS-232 cable from the PC to the ISaGRAF port on the RTU or connect the
Ethernet cable from the PC to the RTU. See Configuring the RTU  for details.

WARNING

UNINTENDED EQUIPMENT OPERATION

Make sure you are connected to the correct RTU before downloading the
solution.

Failure to follow these instructions can result in death, serious injury or
equipment damage.

Click on the Project in the Solution Explorer 

Click the Download button.

WARNING

UNINTENDED EQUIPMENT OPERATION

Evaluate the operational state of the equipment monitored and controlled
by the RTU before downloading. Hazardous situations can occur if
system state is not confirmed prior to downloading.

Failure to follow these instructions can result in death, serious injury or
equipment damage.

12
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Alternatively, right-click on the project and select Download from the menu.

Wait while the project is written to the RTU. The Output window displays progress
messages similar to the following.

------ Download started: Project: SCADAPackSample ------
------ Start Downloading Resource #1 ------
------ Start Downloading Resource #2 ------
------ Download: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ------

If communication is unsuccessful check the communication settings. See Configuring the
RTU , Configuring Serial Communication with the RTU  and/or Configuring Ethernet
Communication with the RTU  .

12 23

24
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5.10 Debugging Programs

The Workbench debugger allows you to view the operation of your programs, and to change
the values of variables.

To start debugging:

Click the Start Debugging button , or press F5, or select Debug > Start Debugging.

WARNING

UNINTENDED EQUIPMENT OPERATION

Evaluate the operational state of the equipment monitored and controlled
by the RTU before debugging. Hazardous situations can occur if system
state is not confirmed prior to debugging.

Failure to follow these instructions can result in death, serious injury or
equipment damage.

Double-click on Prog1 in the Solution Explorer. The execution state of the application is
shown.
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The sample application has two inputs that come from input points. If you don't have real
signals connected to the inputs, the program logic can be tested by locking the input and
writing it's value. To test the logic:

Double-click on the Speed Control variable.

Set Value to 1000.0 (this corresponds to 1000 ms).

Click on the Lock slider so the lock shows ON

Click Write
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Double-click on the Switch1 variable.

Set Value to True.

Click on the Lock slider so the lock shows ON

Click Write

The program will now start cycling the LED outputs.

To see the current state of variables.

Double-click on Local Variables under Prog1 in the Solution Explorer. 

You can modify the logical value and the lock status from this view as well.

To end debugging:

Click the Stop Debugging button , or press Shift+F5, or select Debug > Stop
Debugging.
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See the Workbench Help for more information on debugging.
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